php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6461 Various warnings - not critical but might be helpful to improve the code
Submitted: 2000-08-31 07:12 UTC Modified: 2000-12-04 08:36 UTC
From: cahagn_o at epita dot fr Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.0.2 OS: Digital Unix 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cahagn_o at epita dot fr
New email:
PHP Version: OS:

 

 [2000-08-31 07:12 UTC] cahagn_o at epita dot fr
Hi,

OS: Digital Unix v.4.0 (64-bit)
gcc: 2.7.2.3
This is with PHP 4.0.2 final release.

simple configure line: ./configure

Here're are the various warnings:

php_ini.c: In function `php_ini_refresh_caches':
php_ini.c:165: warning: cast to pointer from integer of
different size
php_virtual_cwd.c: In function `virtual_getcwd':
php_virtual_cwd.c:228: warning: passing arg 1 of
`virtual_getcwd_ex' from incompatible pointer type
php_mysql.c: In function `php_mysql_do_connect':
php_mysql.c:498: warning: cast from pointer to integer of
different size
dl.c:91: warning: `IS_SLASH' redefined
/nfs/s3/space/users/a3/cahagn_o/fichiers/php-4.0.2/main/php_virtual_cwd.h:54:
warning: this is the location of the previous definition
file.c: In function `php_passthru_fd':
file.c:1451: warning: comparison between pointer and integer

(I cannot go further because of lack of processes for my
user on this machine :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-31 07:21 UTC] cahagn_o at epita dot fr
Sorry for the OS mismatch, I changed the OS to the real OS
Digital Unix 4.0.
 [2000-10-30 13:06 UTC] derick@php.net
Thx for this report, but is it possible that you try another build of the new PHP 4.0.3pl1 and see if these warnings still occur? The files have change so much that's not easily found.

 [2000-11-01 06:30 UTC] cahagn_o at epita dot fr
I remember testing snapshots from 2 weeks ago and some of the warnings had disappeared, the only warnings left were 64-bit specific as I could reproduce them on an ia-64 platform with the latest gcc.

However, I now face a new problem I never had, I still compile on the same platform with ./configure --enable-sockets and get these warnings and a compile failure:

Making all in Zend
flex -Pzend -ozend_language_scanner.c -i ./zend_language_scanner.l
flex: unknown flag 'P'
*** Exit 1
Stop.
*** Exit 1
Stop.

This is with native flex version from Digital Unix 4.0
When I try flex 2.5.3, it passes this file but then, with changes in PATH, it's really hard to switch with bison, gcc 2.8.1, etc. so it doesn't really compile. If I can get natve flex to work, I might be able to compile it again.

But the point is that it worked before, through 4.0.3pl and 4.0.4-dev (when sockets.c was fixed) it compiled out-of-the-box.
 [2000-11-29 19:09 UTC] cahagn_o at epita dot fr
With latest snapshot 200011291245 and a simple ./configure,
I only get this warning:

php_mysql.c: In function `php_mysql_do_connect':
php_mysql.c:508: warning: cast from pointer to integer of
different size

It runs fine anyway. Might consider closing this bug report
as the MySQL code is not from the PHP team.
 [2000-12-04 08:36 UTC] sniper@php.net
Closed per user request.

--Jani
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Nov 26 22:05:53 2022 UTC