php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64598 function array dereferencing not completely implemented
Submitted: 2013-04-06 08:06 UTC Modified: 2013-04-06 15:33 UTC
From: php at flyingsoft dot phatcode dot net Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5.4.13 OS: WAMP..
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at flyingsoft dot phatcode dot net
New email:
PHP Version: OS:

 

 [2013-04-06 08:06 UTC] php at flyingsoft dot phatcode dot net
Description:
------------
Function array dereferencing does not work for splFixedArray.

Test script:
---------------
<?php
$a = new splFixedArray(5);
$a[0] = array(1, 2, 3);
$a[0][0] = 10;
?>

Expected result:
----------------
No error.

Actual result:
--------------
"Notice: Indirect modification of overloaded element of SplFixedArray has no effect in [filename] on line 4"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-06 15:33 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2013-04-06 15:33 UTC] felipe@php.net
This nothing have to do with "function array dereferencing".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 01:05:44 2022 UTC