php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64587 Bug in a determinated second...
Submitted: 2013-04-05 05:10 UTC Modified: 2013-04-05 15:13 UTC
From: costanzo_pablo at hotmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
38 - 2 = ?
Subscribe to this entry?

 
 [2013-04-05 05:10 UTC] costanzo_pablo at hotmail dot com
Description:
------------
Date timestamp 1363485599 is little than 1363485600

But... when run date function... 1363485600 is greater than 1363485599

1363485599 = 16/03/2013 23:59:59
1363485600 = 16/03/2013 23:00:00

Test script:
---------------
<?php
echo date("d/m/Y H:i:s", 1363485599).'<br>'.date("d/m/Y H:i:s", 1363485600);
?>

And when execute it...

16/03/2013 23:59:59
16/03/2013 23:00:00

1363485"599"<1363485"600"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-05 05:13 UTC] rasmus@php.net
Which timezone?
 [2013-04-05 05:57 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2013-04-05 05:57 UTC] rasmus@php.net
Well, regardless of the timezone. You have obviously discovered DST in whatever 
timezone you are in. This is not a bug.
 [2013-04-05 15:13 UTC] costanzo_pablo at hotmail dot com
But it would have to happen ...

I'm using date.timezone = America / Buenos_Aires;
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 01:01:28 2024 UTC