php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64576 stream_notification_callback doesn't seem to work
Submitted: 2013-04-03 13:12 UTC Modified: 2013-04-06 15:36 UTC
From: zelnaga at gmail dot com Assigned:
Status: Not a bug Package: Streams related
PHP Version: 5.4.13 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zelnaga at gmail dot com
New email:
PHP Version: OS:

 

 [2013-04-03 13:12 UTC] zelnaga at gmail dot com
Description:
------------
http://www.php.net/manual/en/function.stream-notification-callback.php

Per that I'd wouldn't expect the following test scripts to produce errors but they 
do.

Test script:
---------------
<?php
stream_context_create(array('notification' => 'callback'));
?>

<?php
$ctx = stream_context_create();
stream_context_set_option($ctx, array('notification' => 'callback'));
?>

Expected result:
----------------
(blank)

Actual result:
--------------
Warning: stream_context_create(): options should have the form ["wrappername"]
["optionname"] = $value in /path/to/file.php on line 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-06 15:36 UTC] felipe@php.net
You have called stream_context_set_option() instead of stream_context_set_params().
 [2013-04-06 15:36 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 07 09:01:24 2019 UTC