php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64568 opcache no loadable
Submitted: 2013-04-02 19:48 UTC Modified: 2013-04-03 11:41 UTC
From: bugzilla77 at gmail dot com Assigned:
Status: Not a bug Package: opcache
PHP Version: 5.5.0beta1 OS: windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugzilla77 at gmail dot com
New email:
PHP Version: OS:

 

 [2013-04-02 19:48 UTC] bugzilla77 at gmail dot com
Description:
------------
opcache no loadable

Test script:
---------------
php.ini add: extension=php_opcache.dll

Expected result:
----------------
opcache in phpinfo()

extension_loaded('opcache') returns true

Actual result:
--------------
no opcache in phpinfo()

extension_loaded('opcache') returns false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-02 21:22 UTC] sixd@php.net
-Status: Open +Status: Feedback
 [2013-04-02 21:22 UTC] sixd@php.net
Try Beta 2 and use zend_extension=php_opcache.dll
 [2013-04-03 06:42 UTC] bugzilla77 at gmail dot com
Works,

but ini syntax for dlls is: extension=
not
zend_extension=
 [2013-04-03 08:23 UTC] johannes@php.net
"extension" loads PHP modules, "zend_extension" loads Zend extensions. Those are different things so there are different directives.
 [2013-04-03 11:00 UTC] bugzilla77 at gmail dot com
Add dll automatic detection (extension / Zend extension) for syntax unification.
From the user point view there is no difference.
 [2013-04-03 11:41 UTC] johannes@php.net
There are a few differences, many you won'T really notice (load order, available internal hooks, ...) and some user notable (you can't use dl() on Zend Extensions, there's different reflection, ...) which won't allow easy unification. Especially as there are logical differences (Zend Extensions are loaded by and into the engine, and the engine is more or less independent from "PHP" where PHP extensions (modules) are loaded.

We'll most likely improve the error reporting in this situation: http://news.php.net/php.internals/66909 everything else require major refactoring.

Closing this issue.
 [2013-04-03 11:41 UTC] johannes@php.net
-Status: Feedback +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 19:03:38 2021 UTC