php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64561 new GD ext functions missing from gd_compat.h
Submitted: 2013-04-02 07:02 UTC Modified: 2016-10-17 12:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: ondrej@php.net Assigned: cmb (profile)
Status: Closed Package: GD related
PHP Version: 5.5.0beta1 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ondrej@php.net
New email:
PHP Version: OS:

 

 [2013-04-02 07:02 UTC] ondrej@php.net
Description:
------------
php5 fails to load gd extension due to using symbol only available from bundled 
libgd.

libgd/gd_compat.h misses the definition of gdImagePaletteToTrueColor and the 
function needs to be moved from gd.c to gd_color.c.  (Or something like that.)

And it definitely needs a test in the test suite (or you can finally take over the 
libgd2 and release a new version for everyone, pretty please).

Expected result:
----------------
# php5
#

Actual result:
--------------
# php5
PHP Warning:  PHP Startup: Unable to load dynamic library 
'/usr/lib/php5/20121212+lfs/gd.so' - /usr/lib/php5/20121212+lfs/gd.so: undefined 
symbol: gdImagePaletteToTrueColor in Unknown on line 0
#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-03 06:44 UTC] ondrej@php.net
Same applies for gdImageRotateInterpolated and probably many other new functions 
added.
 [2013-04-03 06:44 UTC] ondrej@php.net
-Summary: gdImagePaletteToTrueColor missing from gd_compat.h +Summary: new GD ext functions missing from gd_compat.h
 [2013-04-03 07:13 UTC] pajoye@php.net
Quick note, only the generic functions (affine, rotate, scale and set 
interpolation method) will be added to userland.
 [2016-10-17 11:51 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2016-10-17 11:51 UTC] cmb@php.net
Ondřej, hasn't this issue been already resolved?
 [2016-10-17 12:11 UTC] ondrej@php.net
-Status: Feedback +Status: Closed
 [2016-10-17 12:11 UTC] ondrej@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Yeah.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 13:01:29 2024 UTC