php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #64532 Documentation doesn't say what date time format is returned
Submitted: 2013-03-27 11:03 UTC Modified: 2013-03-27 12:21 UTC
From: copong at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: copong at gmail dot com
New email:
PHP Version: OS:

 

 [2013-03-27 11:03 UTC] copong at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.filemtime#refsect1-
function.filemtime-description
---

It returns a UNIX timestamp. Documentation should reflect this - how do I know it 
doesn't return a DateTime object, for example?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-27 12:21 UTC] salathe@php.net
-Status: Open +Status: Not a bug
 [2013-03-27 12:21 UTC] salathe@php.net
The page already states:

    The time is returned as a Unix timestamp, which is suitable for the date() 
function.

And the function prototype at the top of the page says:

    int filemtime ( string $filename )

That should be information enough to know it doesn't return a DateTime object.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC