php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64491 float numbers won't add up
Submitted: 2013-03-22 14:09 UTC Modified: 2013-03-22 14:13 UTC
From: mihai at iorga dot eu Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.4.13 OS: any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mihai at iorga dot eu
New email:
PHP Version: OS:

 

 [2013-03-22 14:09 UTC] mihai at iorga dot eu
Description:
------------
echo (int)((0.1 + 0.7) * 10);

Test script:
---------------
echo (int)((0.1 + 0.7) * 10);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-22 14:13 UTC] nikic@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 [2013-03-22 14:13 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 12:01:27 2024 UTC