php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #64466 GmagickPixel does not support cmyk notation in constructor
Submitted: 2013-03-20 15:42 UTC Modified: 2015-12-31 20:16 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: imprec at gmail dot com Assigned:
Status: Not a bug Package: gmagick (PECL)
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: imprec at gmail dot com
New email:
PHP Version: OS:

 

 [2013-03-20 15:42 UTC] imprec at gmail dot com
Description:
------------
This code fails :

new GmagickPixel('cmyk(10%, 0%, 0%, 0%)');

This code fails too :

new GmagickPixel('cmyk(10, 0, 0, 0)');


Whereas ImagickPixel instantiation with such values works great.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-31 20:16 UTC] danack@php.net
-Status: Open +Status: Not a bug
 [2015-12-31 20:16 UTC] danack@php.net
GraphicsMagick, the underlying library for Gmagick, does not support CMYK for the constructor. http://www.graphicsmagick.org/wand/magick_wand.html

Please request this as a feature upstream at http://sourceforge.net/p/graphicsmagick/bugs/
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 16 21:01:23 2021 UTC