|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64445 Cannot load php_soap.dll
Submitted: 2013-03-18 16:00 UTC Modified: 2013-10-15 11:54 UTC
Avg. Score:4.4 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:2 (40.0%)
From: blasterdrp at gmail dot com Assigned:
Status: No Feedback Package: Dynamic loading
PHP Version: 5.4.13 OS: Windows XP x86 SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: blasterdrp at gmail dot com
New email:
PHP Version: OS:


 [2013-03-18 16:00 UTC] blasterdrp at gmail dot com
Unzipped contents to a new PHP branch directory. Copied php.ini.development as 
php.ini then opened it side-by-side with previous php.ini (5.4.9) to ensure that 
the same settings had the same values to avoid hastily setting values for 
configurations I was not aware of.

I receive the following error message when starting my Apache server:

"PHP Startup: Unable to load dynamic library 'C:\Program 
Files\PHP\5.4.13\ext\php_soap.dll' - The specified procedure could not be 

Navigating to that directory I can clearly see php_soap.dll. This is the only 
extension that will not load. I have also redownloaded PHP to ensure that this 
particular library was not corrupted.


extension_dir = "C:\Program Files\PHP\5.4.13\ext"



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-19 13:12 UTC] blasterdrp at gmail dot com
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.4.13\\ext\\php_soap.dll' - The specified procedure could
not be found.\r\n in Unknown on line 0
 [2013-03-21 10:21 UTC]
-Status: Open +Status: Feedback
 [2013-03-21 10:21 UTC]
Just tried that with apache 2.4.4 and php 5.4.13 on win8. I could reproduce this only if I set a relative path like extension_dir=ext, giving full path works. However that space in your path looks suspicious to me, though it worked for me on win8 too. Could you please try to remove the space from that path?
 [2013-10-15 11:54 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 13 17:01:32 2024 UTC