php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64436 The module does not build
Submitted: 2013-03-15 22:27 UTC Modified: 2017-04-01 20:18 UTC
From: fabreg at gmail dot com Assigned:
Status: Wont fix Package: funcall (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fabreg at gmail dot com
New email:
PHP Version: OS:

 

 [2013-03-15 22:27 UTC] fabreg at gmail dot com
Description:
------------
The module does not build on php 5.4.3
After a successful configure, make fails:

# make
/bin/sh /root/funcall-0.3.0alpha/libtool --mode=compile cc  -I. -I/root/funcall-
0.3.0alpha -DPHP_ATOM_INC -I/root/funcall-0.3.0alpha/include -I/root/funcall-
0.3.0alpha/main -I/root/funcall-0.3.0alpha -I/usr/local/php54/include/php -
I/usr/local/php54/include/php/main -I/usr/local/php54/include/php/TSRM -
I/usr/local/php54/include/php/Zend -I/usr/local/php54/include/php/ext -
I/usr/local/php54/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c 
/root/funcall-0.3.0alpha/funcall.c -o funcall.lo 
mkdir .libs
 cc -I. -I/root/funcall-0.3.0alpha -DPHP_ATOM_INC -I/root/funcall-
0.3.0alpha/include -I/root/funcall-0.3.0alpha/main -I/root/funcall-0.3.0alpha -
I/usr/local/php54/include/php -I/usr/local/php54/include/php/main -
I/usr/local/php54/include/php/TSRM -I/usr/local/php54/include/php/Zend -
I/usr/local/php54/include/php/ext -I/usr/local/php54/include/php/ext/date/lib -
DHAVE_CONFIG_H -g -O2 -c /root/funcall-0.3.0alpha/funcall.c  -fPIC -DPIC -o 
.libs/funcall.o
In file included from /root/funcall-0.3.0alpha/funcall.c:25:
/root/funcall-0.3.0alpha/php_funcall.h: In function ‘fg_zval_ptr’:
/root/funcall-0.3.0alpha/php_funcall.h:101: error: ‘union <anonymous>’ has no 
member named ‘var’
/root/funcall-0.3.0alpha/php_funcall.h:104: error: ‘union <anonymous>’ has no 
member named ‘var’
/root/funcall-0.3.0alpha/php_funcall.h:105: error: ‘union <anonymous>’ has no 
member named ‘var’
/root/funcall-0.3.0alpha/php_funcall.h:107: error: ‘union <anonymous>’ has no 
member named ‘var’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_get_zval’:
/root/funcall-0.3.0alpha/funcall.c:103: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c:108: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c:109: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_include_or_eval_handler’:
/root/funcall-0.3.0alpha/funcall.c:140: warning: passing argument 1 of ‘printf’ 
from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c:143: error: ‘znode_op’ has no member named 
‘u’
/root/funcall-0.3.0alpha/funcall.c:149: warning: passing argument 2 of 
‘fc_get_zval’ from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c:167: warning: assignment makes pointer from 
integer without a cast
/root/funcall-0.3.0alpha/funcall.c:168: warning: passing argument 1 of ‘printf’ 
from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c: In function ‘get_current_function_name’:
/root/funcall-0.3.0alpha/funcall.c:430: warning: passing argument 1 of 
‘get_active_class_name’ from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c:430: warning: assignment discards qualifiers 
from pointer target type
/root/funcall-0.3.0alpha/funcall.c:433: warning: initialization discards 
qualifiers from pointer target type
/root/funcall-0.3.0alpha/funcall.c:440: warning: assignment discards qualifiers 
from pointer target type
/root/funcall-0.3.0alpha/funcall.c:455: error: ‘znode_op’ has no member named 
‘op_type’
/root/funcall-0.3.0alpha/funcall.c:456: error: ‘znode_op’ has no member named 
‘u’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_get_zval_ptr_tmp’:
/root/funcall-0.3.0alpha/funcall.c:476: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_get_zval_ptr_cv’:
/root/funcall-0.3.0alpha/funcall.c:481: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c:484: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c: In function 
‘_get_zval_ptr_var_string_offset’:
/root/funcall-0.3.0alpha/funcall.c:496: error: ‘const union <anonymous>’ has no 
member named ‘var’
/root/funcall-0.3.0alpha/funcall.c:502: error: ‘struct <anonymous>’ has no 
member named ‘ptr’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_get_zval_ptr_var’:
/root/funcall-0.3.0alpha/funcall.c:544: error: ‘union <anonymous>’ has no member 
named ‘var’
/root/funcall-0.3.0alpha/funcall.c: In function ‘get_inc_filename’:
/root/funcall-0.3.0alpha/funcall.c:606: error: ‘znode_op’ has no member named 
‘op_type’
/root/funcall-0.3.0alpha/funcall.c:608: error: ‘znode_op’ has no member named 
‘u’
/root/funcall-0.3.0alpha/funcall.c:613: warning: passing argument 1 of 
‘fc_get_zval_ptr_tmp’ from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c:619: warning: passing argument 1 of 
‘fc_get_zval_ptr_cv’ from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c:626: warning: passing argument 1 of 
‘fc_get_zval_ptr_var’ from incompatible pointer type
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_add_callback’:
/root/funcall-0.3.0alpha/funcall.c:728: error: expected ‘;’ before ‘(’ token
/root/funcall-0.3.0alpha/funcall.c:731: error: expected ‘;’ before ‘(’ token
/root/funcall-0.3.0alpha/funcall.c:747: error: expected ‘;’ before ‘new_gfl’
/root/funcall-0.3.0alpha/funcall.c:757: error: expected ‘;’ before ‘cl’
/root/funcall-0.3.0alpha/funcall.c:765: error: expected ‘;’ before ‘new_cl’
/root/funcall-0.3.0alpha/funcall.c: In function ‘fc_execute_internal’:
/root/funcall-0.3.0alpha/funcall.c:963: error: ‘znode_op’ has no member named 
‘u’
make: *** [funcall.lo] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-21 11:26 UTC] kalle@php.net
Confirmed, this does not build on 5.4 or 5.5
 [2013-03-21 11:26 UTC] kalle@php.net
-Status: Open +Status: Verified -Operating System: CentOS release 5.7 +Operating System: Irrelevant
 [2017-04-01 20:18 UTC] tpunt@php.net
-Status: Verified +Status: Wont fix
 [2017-04-01 20:18 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 08:01:30 2019 UTC