php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64336 [ZOOKEEPER] extension does not compile against PHP 5.4
Submitted: 2013-03-02 12:40 UTC Modified: 2018-09-24 22:08 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: stuart at stuartherbert dot com Assigned: cmb (profile)
Status: Closed Package: PECL (PECL)
PHP Version: 5.4.12 OS: Ubuntu 12.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stuart at stuartherbert dot com
New email:
PHP Version: OS:

 

 [2013-03-02 12:40 UTC] stuart at stuartherbert dot com
Description:
------------
Compile error when attempting to compile the PECL extension 'Zookeeper' against 
PHP 5.4.  The problem is that it uses an old API to initialise the Zookeeper 
zend_class_entry.

Test script:
---------------
phpize
./configure --enable-zookeeper
make

Expected result:
----------------
I expect the PECL extension to compile

Actual result:
--------------
libtool: compile:  cc -I/usr/include/php5 -I. -I/tmp/pear/temp/zookeeper -
DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-root7GuWXy/zookeeper-0.2.1/include -
I/tmp/pear/temp/pear-build-root7GuWXy/zookeeper-0.2.1/main -
I/tmp/pear/temp/zookeeper -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib -I/usr/include/zookeeper -DHAVE_CONFIG_H -g -O2 -
c /tmp/pear/temp/zookeeper/php_zookeeper.c  -fPIC -DPIC -o .libs/php_zookeeper.o
/tmp/pear/temp/zookeeper/php_zookeeper.c: In function 'php_zk_new':
/tmp/pear/temp/zookeeper/php_zookeeper.c:718:45: error: 'zend_class_entry' has no 
member named 'default_properties'
make: *** [php_zookeeper.lo] Error 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-02 13:30 UTC] shuimuqingshu at gmail dot com
I resolve this problem. may be this is a php bug.
here is the code: https://github.com/JeremyWei/php-zookeeper
 [2017-10-24 08:56 UTC] kalle@php.net
-Summary: PECL-Zookeeper extension does not compile against PHP 5.4 +Summary: [ZOOKEEPER] extension does not compile against PHP 5.4
 [2018-09-24 22:08 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2018-09-24 22:08 UTC] cmb@php.net
This has been reported for zookeeper 0.2.1, but 0.2.2 claims PHP
5.4 compatibility[1], so this issue appears to have been resolved
long ago.

[1] <https://pecl.php.net/package-changelog.php?package=zookeeper&release=0.2.2>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC