php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64305 apc_delete fails - user cache entry not deleted
Submitted: 2013-02-26 22:55 UTC Modified: 2013-02-28 06:03 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mayhem30 at gmail dot com Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.3.22 OS: FreeBSD 8.3 (x64)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mayhem30 at gmail dot com
New email:
PHP Version: OS:

 

 [2013-02-26 22:55 UTC] mayhem30 at gmail dot com
Description:
------------
'apc_delete' will no longer delete a user cache entry.

Test script:
---------------
var_dump( apc_delete("news_$id") );

This always returns false. It's been this way for 3.1.12 and 3.1.13

Expected result:
----------------
To return true and delete the specified user cache entry.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-27 18:21 UTC] mayhem30 at gmail dot com
Updated OS information to reflect 64 bit.
 [2013-02-27 18:21 UTC] mayhem30 at gmail dot com
-Operating System: FreeBSD 8.3 +Operating System: FreeBSD 8.3 (x64)
 [2013-02-28 02:56 UTC] laruence@php.net
there maybe some thing wrong with "new_$id", maybe it turn out not a valid apc 
sotred entry key?

otherwise, I can image what's maybe wrong there.
 [2013-02-28 02:56 UTC] laruence@php.net
-Status: Open +Status: Feedback
 [2013-02-28 03:24 UTC] mayhem30 at gmail dot com
It appears you are correct - even though I have tested many times to make sure my news script was passing the correct variables, I am able to store/delete user cache entries if my news (apc php code part) is moved into a seperate file.

What's weird is that I have made no modifications whatsoever to my news script and the php function broke on it's own since updating to 3.1.12 (and 3.1.13)

I apologize for wasting your time.
 [2013-02-28 03:24 UTC] mayhem30 at gmail dot com
-Status: Feedback +Status: Open
 [2013-02-28 06:03 UTC] laruence@php.net
you are welcome. closed as Not a bug
 [2013-02-28 06:03 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 22 17:01:24 2021 UTC