php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64275 open_basedir with multiple folders
Submitted: 2013-02-22 12:01 UTC Modified: 2014-01-10 20:57 UTC
From: ava1973 at hotmail dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 5.4.12 OS: Windows Server 2008 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ava1973 at hotmail dot com
New email:
PHP Version: OS:

 

 [2013-02-22 12:01 UTC] ava1973 at hotmail dot com
Description:
------------
Hello,

Upgrading a bunch of older application to new servers, i get the hand to a 
strange 
behaviour:
* currently done with PHP 5.4.11 with IIS 7.5 (windows 2008R2)
* use simple phpinfo() to reveal Open_basedir values
* defined in php.ini
open_basedir = D:\APPS\xxx\;C:\windows\temp\
* Idea is to allow OLD applications to be restriced to their application path 
AND the windows temp folder. Otherwhise too many change to implement to their 
code.

* according to manual, this looks supported using semi-colum for windows
http://www.php.net/manual/en/ini.core.php#ini.open-basedir

Test script:
---------------
<?php phpinfo();?>

Expected result:
----------------
...
open_basedir D:\APPS\xxx\;C:\windows\temp\ D:\APPS\xxx\;C:\windows\temp\ 
...

Actual result:
--------------
...
open_basedir D:\APPS\xxx\ D:\APPS\xxx\ 
...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-24 05:35 UTC] yohgaki@php.net
-Operating System: w2k8r2 +Operating System: Windows Server 2008 R2
 [2014-01-10 20:57 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2014-01-10 20:57 UTC] ab@php.net
open_basedir = 'D:\APPS\xxx\;C:\windows\temp\' should be probably it.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 05:05:45 2022 UTC