php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64227 current() function does not require a reference
Submitted: 2013-02-16 11:12 UTC Modified: 2014-05-29 09:51 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: schmittjoh at gmail dot com Assigned: kriscraig (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: schmittjoh at gmail dot com
New email:
PHP Version: OS:

 

 [2013-02-16 11:12 UTC] schmittjoh at gmail dot com
Description:
------------
The API documentation for ``current()`` currently declares the first parameter to be a reference. In fact however, it accepts any expression, not only references.

http://www.php.net/manual/en/function.current.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-19 18:30 UTC] kriscraig@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: kriscraig
 [2013-02-19 18:30 UTC] kriscraig@php.net
Confirmed.  Doc entry will need to be corrected.
 [2013-02-20 04:02 UTC] laruence@php.net
actually, it is not a bug, current declares prefer send_by_ref.
 [2013-02-20 12:27 UTC] schmittjoh at gmail dot com
@laruence, could you elaborate what that means?
 [2014-05-29 09:51 UTC] kriscraig@php.net
-Status: Assigned +Status: Not a bug
 [2014-05-29 09:51 UTC] kriscraig@php.net
No feedback for over a year.  Laruence says it's not a bug.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 07:01:24 2020 UTC