php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64158 php://stderr stream logs to global apache log file instead of virtual host file
Submitted: 2013-02-05 14:25 UTC Modified: 2014-04-03 11:42 UTC
From: mp at webfactory dot de Assigned:
Status: Duplicate Package: Streams related
PHP Version: 5.3.21 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
31 - 9 = ?
Subscribe to this entry?

 
 [2013-02-05 14:25 UTC] mp at webfactory dot de
Description:
------------
When running under Apache, it would be nice if output written to php://stderr 
would get to the error log. This is default for CGI processes 
(http://httpd.apache.org/docs/2.2/logs.html) and the way trigger_error works.

Actually, this is a duplicate of bug 51304, which has been set to "no feedback" 
and the OP seems no longer be interested to help. 

(Otherwise, please educate me how I can re-open that bug and become responsible 
for providing the feedback required?)





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-03 11:42 UTC] mike@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Dec 11 14:01:24 2019 UTC