php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64147 A few missing constants.
Submitted: 2013-02-04 21:53 UTC Modified: 2013-02-04 21:56 UTC
From: superspring at gmail dot com Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 5.3.21 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: superspring at gmail dot com
New email:
PHP Version: OS:

 

 [2013-02-04 21:53 UTC] superspring at gmail dot com
Description:
------------
I am unable to find the constants
- ENT_SUBSTITUTE
- ENT_DISALLOWED
- ENT_HTML401
- ENT_XML1
- ENT_XHTML
- ENT_HTML5
As used in htmlentities.

Test script:
---------------
echo htmlentities('example text', ENT_XHTML);

Expected result:
----------------
Not to throw a warning.

Actual result:
--------------
A warning is thrown.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-04 21:56 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2013-02-04 21:56 UTC] rasmus@php.net
The docs clearly state that these were added in PHP 5.4
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 02:05:44 2022 UTC