php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64141 apc_copy_op_array segfaults when running php 5.4 if apc_pool_alloc() fails
Submitted: 2013-02-04 13:36 UTC Modified: 2013-02-04 20:51 UTC
From: lazy at iq dot pl Assigned:
Status: Closed Package: APC (PECL)
PHP Version: 5.4.11 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lazy at iq dot pl
New email:
PHP Version: OS:

 

 [2013-02-04 13:36 UTC] lazy at iq dot pl
Description:
------------
apc_copy_op_array segfaults when running php 5.4 if apc_pool_alloc() fails,
attached a patch adding missing CHECK

there are other apc_pool_alloc without checks

eg. 
dzo->op1.literal = (zend_literal*) apc_pool_alloc(pool, sizeof(zend_literal)); 
in apc_copy_op_array() apc_compile.c

but I'm not sure if CHECK is the correct way to handle those alloc errors


Patches

check_for_failed_apc_pool_alloc.patch (last revision 2013-02-04 13:36 UTC by lazy at iq dot pl)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-04 20:51 UTC] lazy at iq dot pl
now I found that this is a duplicate of

https://bugs.php.net/bug.php?id=64064
 [2013-02-04 20:51 UTC] lazy at iq dot pl
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 07:03:34 2022 UTC