php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64062 cannot transfer files with ssh2_scp_send >80KB
Submitted: 2013-01-24 13:55 UTC Modified: 2013-01-28 12:47 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: verbeamt at gmx dot net Assigned:
Status: Closed Package: ssh2 (PECL)
PHP Version: Irrelevant OS: gentoo linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: verbeamt at gmx dot net
New email:
PHP Version: OS:

 

 [2013-01-24 13:55 UTC] verbeamt at gmx dot net
Description:
------------
I'm not able to transfer file bigger 80KB using ssh2_scp_send.
Files smaller 80KB work as expected.

net-libs/libssh2 version 1.4.2
dev-php/pecl-ssh2 version 0.11.3-r1
php dev-lang/php version 5.3.15
also tested with dev-lang/php version 5.4.6 same effects here

php compiled with following use-flags

apache2 berkdb bzip2 cli crypt ctype curl fileinfo filter ftp gdbm hash iconv ipv6 json mysql mysqli nls pcntl pdo phar posix readline session simplexml ssl threads tokenizer unicode xml zlib



Test script:
---------------
ssh2_scp_send($conn_ssh, $local_file, $remote_file, 0666)

Expected result:
----------------
I expect the file to be transfered

Actual result:
--------------
PHP Warning:  ssh2_scp_send(): Failed copying file ...

File is transfered until size of about 80KB is reached then process breaks.

Are there any limits which have to be configured?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-28 12:46 UTC] verbeamt at gmx dot net
Looks like this is fixed with dev-php/pecl-ssh2 version 0.12
 [2013-01-28 12:47 UTC] verbeamt at gmx dot net
looks like this is fixed in dev-php/pecl-ssh2 version 0.12
 [2013-01-28 12:47 UTC] verbeamt at gmx dot net
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 28 04:01:23 2020 UTC