php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63956 How can i get the process id using WScript.Shell calss
Submitted: 2013-01-10 07:12 UTC Modified: 2013-01-10 07:13 UTC
From: ajeenaa dot shanmugan at gmailc dot om Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.3.20 OS: windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ajeenaa dot shanmugan at gmailc dot om
New email:
PHP Version: OS:

 

 [2013-01-10 07:12 UTC] ajeenaa dot shanmugan at gmailc dot om
Description:
------------
I have one problem. I am running a process in background uisng 

$WshShell = new COM("WScript.Shell");

$oExec = $WshShell->Run($cmd,0,false);

How do i know that the background process is done or still running so that i can wait for it.

I am keeping log file for that.

Please help me.

Test script:
---------------
I have one problem. I am running a process in background uisng 

$WshShell = new COM("WScript.Shell");

$oExec = $WshShell->Run($cmd,0,false);

How do i know that the background process is done or still running so that i can wait for it.

I am keeping log file for that.

Please help me.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-10 07:13 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2013-01-10 07:13 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 18:03:50 2022 UTC