php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63939 Why GMagick::getCompressionQuality does not exists?
Submitted: 2013-01-08 10:22 UTC Modified: 2013-10-19 09:12 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jeremy dot benoist at gmail dot com Assigned: vito (profile)
Status: Closed Package: gmagick (PECL)
PHP Version: 5.3.20 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeremy dot benoist at gmail dot com
New email:
PHP Version: OS:

 

 [2013-01-08 10:22 UTC] jeremy dot benoist at gmail dot com
Description:
------------
I'm using both Imagick & Gmagick. For a given image, I want to retrieve the 
compression quality when I load the image resource.

It works fine using Imagick, because the `getCompressionQuality` is implemented. 
But it doesn't work with Gmagick.

Gmagick has implemented `setCompressionQuality` - which isn't in the documentation 
btw (see #59005 & http://svn.php.net/viewvc?view=revision&revision=293077) but why 
`getCompressionQuality` has not been implemented?

Test script:
---------------
$img = new Gmagick();
$img->readImage($src);
$img->setCompressionQuality(90);

Expected result:
----------------
No error.

Actual result:
--------------
PHP Fatal error:  Call to undefined method Gmagick::getCompressionQuality()


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-19 09:12 UTC] vito@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: vito
 [2013-10-19 09:12 UTC] vito@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This mirrors the magick_wand available here:

http://www.graphicsmagick.org/wand/magick_wand.html

for which MagickGetCompressionQuality isn't available as well.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 11:01:29 2024 UTC