php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6387 gettimeofday, microtime
Submitted: 2000-08-27 23:24 UTC Modified: 2001-04-27 19:26 UTC
From: Howard dot Cohodas at dkt dot com Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.2 OS: NT4 SP6a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Howard dot Cohodas at dkt dot com
New email:
PHP Version: OS:

 

 [2000-08-27 23:24 UTC] Howard dot Cohodas at dkt dot com
Configuration...
php-4.0.2-dev-Win32-24-8-2000.zip
WinNT4 SP6a
HTTP Server: WebSitePro/2.5.4
mySQL: 3.23.22-beta
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Reference Bug id #4968

Detailed analysis...
1. gettimeofday["usec"] rolls over at 2^28 (268435456),
   0x10000000.

2. gettimeofday["sec"] matches the sec part of microtime.

3. microtime usec part doesn't make sense.



Step  gettimeofday  gettimeofday      microtime()
        ["sec"]       ["usec"]
  0    967420710     211538813    0.59538100 967420710
  1    967420710     234563948    0.61163700 967420710
  2    967420710     257593663    0.63787700 967420710
  3    967420710      12374818    0.41981500 967420710
  4    967420710      35520302    0.57713500 967420710
  5    967420710      58584974    0.64555500 967420710
  6    967420710      81863117    0.90895600 967420710
  7    967420710     105074610    0.11944100 967420710
  8    967420710     128243173    0.28740700 967420710
  9    967420710     152468688    0.51729200 967420710
 10    967420710     176315729    0.37172700 967420710
 11    967420710     199385514    0.43058200 967420710
 12    967420711     222686394    0.73147500 967420711
 13    967420711     245712656    0.75936400 967420711
 14    967420711        329644    0.37217300 967420711
 15    967420711      23490434    0.54617500 967420711
 16    967420711      46427158    0.47022600 967420711
 17    967420711      69987043    0.03922000 967420711
 18    967420711      93276661    0.33045300 967420711
 19    967420711     116411244    0.46147700 967420711
 20    967420711     139507124    0.55288700 967420711
 21    967420711     162421852    0.46674600 967420711
 22    967420711     185522697    0.56657600 967420711
 23    967420711     208792211    0.83706300 967420711
 24    967420711     231552785    0.59555600 967420711
 25    967420712     254410187    0.46185000 967420712

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-30 08:30 UTC] Howard dot Cohodas at dkt dot com
Bug persists in PHP4.0.2
 [2001-01-13 20:42 UTC] sniper@php.net
Duplicate of  #4968

 [2001-04-27 19:26 UTC] sniper@php.net
fixed
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC