php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63856 --prefix is not recognized by configure for all libraries
Submitted: 2012-12-26 14:14 UTC Modified: 2013-01-08 03:29 UTC
From: mamfelt at gmail dot com Assigned:
Status: Duplicate Package: *Compile Issues
PHP Version: 5.3.20 OS: AIX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mamfelt at gmail dot com
New email:
PHP Version: OS:

 

 [2012-12-26 14:14 UTC] mamfelt at gmail dot com
Description:
------------
Running
CFLAGS=-O2 -qcpluscmt ./configure \ 
        --prefix=/opt \ 
        --sysconfdir=/var/php/etc \ 
        --sharedstatedir=/var/php/com \ 
        --localstatedir=/var/php \ 
        --mandir=/usr/share/man

fails because it does not find files in ${prefix}/lib and/or ${prefix}/include

Test script:
---------------
CFLAGS=-O2 -qcpluscmt ./configure \ 
        --prefix=/opt \ 
        --sysconfdir=/var/php/etc --sharedstatedir=/var/php/com \ 
        --localstatedir=/var/php  --mandir=/usr/share/man


Expected result:
----------------
+ make install DESTDIR=/var/tmp/root/php-5.3.20.0 > build/aix/install.out
+ mkinstallp.ksh /var/tmp/root/php-5.3.20.0 > build/aix/mkinstallp.out
==============================
aixtools.php:aixtools.php.man:5.3.20.0::I:T:::::N:php man pages 2012.Dec.26 13.51 CUT::::0::
aixtools.php:aixtools.php.rte:5.3.20.0::I:T:::::N:php 5.3.20.0 2012.Dec.26 13.51 CUT::::0::
==============================


Actual result:
--------------
...
configure:20951: cc -o conftest -O2 -qcpluscmt   conftest.c -lrt -lm  1>&5
configure:20923: checking for strftime
configure:21413: checking which regex library to use
configure:21830: checking whether to enable LIBXML support
configure:21875: checking libxml2 install dir
configure:21901: checking for xml2-config path

Usage: configure [options] [host]
...
Directory and file names:
  --prefix=PREFIX         install architecture-independent files in PREFIX
                          [/usr/local]
...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-26 14:19 UTC] mamfelt at gmail dot com
To resolve this I do the following:
vi ./configure
:1,$s/\/usr\/local/\/opt/g
:wq

And repeat the configure command, which create a Makefile that compiles successfully.

No idea if it is an autoconf error (that is generating the configure script, or if new input is needed - as only SOME libraries fail (libxml2 is the first to fail).
 [2012-12-26 23:50 UTC] mamfelt at gmail dot com
my apologies. forgot i had already submitted as #63221, please ignore. :blush:
 [2013-01-08 03:29 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 00:01:24 2020 UTC