php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63658 Declare function is a reserved PHP keyword
Submitted: 2012-11-30 12:34 UTC Modified: 2012-11-30 15:22 UTC
From: florinpatan at gmail dot com Assigned:
Status: Closed Package: amqp (PECL)
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: florinpatan at gmail dot com
New email:
PHP Version: OS:

 

 [2012-11-30 12:34 UTC] florinpatan at gmail dot com
Description:
------------
Hello,

The declare method from AMQPExchange and AMQPQueue will make the extending classes impossible to overwrite that method as declare is a reserved keyword which will create an error when trying to be declared in a class.

Please fix this.

Thank you!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-30 15:04 UTC] bkw at codingforce dot com
Dupe of #62640. This has been adressed be renaming the methods in question to 
declareQueue and declareExchange respectively, see 
https://github.com/pdezwart/php-amqp/pull/2 .

Unfortunately we currently cannot update the documentation (php.net account 
request pending). Please excuse the inconvenience.
 [2012-11-30 15:22 UTC] florinpatan at gmail dot com
-Status: Open +Status: Closed
 [2012-11-30 15:22 UTC] florinpatan at gmail dot com
Is there any way to help you out getting the documentation account faster? Have you tried #php.pecl on IRC?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 12:03:38 2021 UTC