|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63606 "HTTP request failed!" on HTTPS request through stream wrapper
Submitted: 2012-11-26 11:41 UTC Modified: 2020-11-22 04:22 UTC
Avg. Score:3.7 ± 1.9
Reproduced:1 of 3 (33.3%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mikael at webhallen dot com Assigned: cmb (profile)
Status: No Feedback Package: Streams related
PHP Version: 5.4.9 OS: linux/debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: mikael at webhallen dot com
New email:
PHP Version: OS:


 [2012-11-26 11:41 UTC] mikael at webhallen dot com
I'm giving you the specific server in the script because I have not been able to 
reproduce the problem using any other server. It also works in PHP5.3 on the same 
server. I do not administer the server in question. I have tried using an MITM 
proxy, but that worked instead of giving me relevant errors. I've tried using 
openssl's s_client and manually send HTTP commands. That too, worked.
libcurl works, wget works. It's just the php stream wrapper that doesn't work and 
I do not feel like I possess the necessary knowledge to know how to continue 
debugging this.

Sadly, I'm currently using the SoapClient in PHP for the implementation so it's 
not a cake walk to rewrite it using libcurl instead.

Any help appreciated!

Test script:
echo file_get_contents(;

Expected result:
WSDL-definition printed out.

Actual result:
200 second timeout until error message:
Warning: file_get_contents(
wsdl): failed to open stream: HTTP request failed!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-09 17:13 UTC]
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2020-11-09 17:13 UTC]
Is this still an issue with any of the actively supported PHP

[1] <>
 [2020-11-22 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 13:01:29 2024 UTC