|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63511 PECL extension fails with an error
Submitted: 2012-11-14 11:31 UTC Modified: 2012-11-15 09:07 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: simplyadilb at gmail dot com Assigned: ab (profile)
Status: Closed Package: Trader (PECL)
PHP Version: Irrelevant OS: Ubuntu 11.10 x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
13 + 37 = ?
Subscribe to this entry?

 [2012-11-14 11:31 UTC] simplyadilb at gmail dot com
Installation fails with an error

sudo pecl install trader-beta


downloading trader-0.3.0.tgz ...
Starting to download trader-0.3.0.tgz (295,748 bytes)

/tmp/pear/temp/trader/trader.c:1225:2: error: 'PHP_FE_END' undeclared here (not 
in a function)
make: *** [trader.lo] Error 1

Test script:
sudo pecl install trader-beta


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-14 12:42 UTC]
-Package: Compile Failure +Package: Trader
 [2012-11-14 14:31 UTC]
PHP_FE_END was added in PHP 5.3. You are most likely  using PHP 5.2 (or older)
 [2012-11-14 14:33 UTC] simplyadilb at gmail dot com
Nope. Its php 5.3 alright.

PHP 5.3.6-13ubuntu3.9 with Suhosin-Patch (cli) (built: Sep 12 2012 19:00:27) 
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
 [2012-11-14 18:16 UTC]
-Status: Open +Status: Feedback -Assigned To: +Assigned To: ab
 [2012-11-14 18:16 UTC]
That was fixed in bug #62832, yet in trunk. PHP_FE_END was added somewhere in the middle of PHP 5.3 :) . Use trunk for now or just upgrade PHP.

What looks strange to me is that 0.3.0 is stable so i just wonder how you could get it with trader-beta.
 [2012-11-15 08:34 UTC] simplyadilb at gmail dot com
I upgraded PHP via the dotdeb reps ( to PHP 
5.3.18 . It still breaks.

Also, with "pecl install trader" i was getting v0.2 earlier, but now i'm getting 
 [2012-11-15 08:34 UTC] simplyadilb at gmail dot com
-Status: Feedback +Status: Assigned
 [2012-11-15 08:54 UTC]
Seems like you had the beta state as default. Anyway, starting with 5.3.10 it will compile for sure. If you look into the  bug #62832 - there it was compiling with 5.3.15.

What is exactly the break right now? Could you please reset the pecl cache and try again?
 [2012-11-15 08:54 UTC] simplyadilb at gmail dot com
I had to manually patch v0.3 based on the instructions here . Works now.
 [2012-11-15 08:59 UTC] simplyadilb at gmail dot com
> What is exactly the break right now? Could you please reset the pecl cache and 
try again?

Same error, even after "pecl clear-cache"
 [2012-11-15 09:07 UTC]
Ok, strange. May be dotdeb sources differ somehow, didn't look into them though. Looks like the trunk has to be released then as a lot of people use dotdeb. Nevertheless that's only the fix after the last release.

Thanks for reporting :)
 [2012-11-15 09:07 UTC]
-Status: Assigned +Status: Closed
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Jan 29 16:05:54 2023 UTC