php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #63332 The problem with __ toString and PDO.
Submitted: 2012-10-22 13:14 UTC Modified: 2012-10-22 13:20 UTC
From: jacek dot strzemieczny251 at gmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.3.18 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jacek dot strzemieczny251 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-10-22 13:14 UTC] jacek dot strzemieczny251 at gmail dot com
Description:
------------
My problem is __ toString malfunction at the junction of queries PDO.

Test script:
---------------
http://wklejto.pl/136115
http://wklejto.pl/136116
http://wklejto.pl/136117

Expected result:
----------------
( ! ) Catchable fatal error: Method szablon::__toString() must return a string value in C:\wamp\www\CMS\skrypty\PHP\IOBazaDanych.php on line 84
Call Stack
# Time Memory Function Location
1 0.0005 382344 {main}( ) ..\zakladanie konta.php:0
2 0.0209 451320 bazaDanych->wykonajKwerende( ) ..\zakladanie konta.php:25


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-22 13:20 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-10-22 13:20 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This appears to be caused by the fact that the $tresc property in the 
bazaDanych::$kwerenda variable created in utworzKwerende() is set to an object, 
rather than a string.

At any rate, I would suggest working through this issue with one of the support 
channels listed above, as it doesn't appear to be a PHP bug.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 09:01:30 2024 UTC