php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63303 adding 2 decimals number, returned 13 decimal point ?
Submitted: 2012-10-18 09:37 UTC Modified: 2012-10-18 14:17 UTC
From: mikeyap2005 at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.3.17 OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mikeyap2005 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-10-18 09:37 UTC] mikeyap2005 at gmail dot com
Description:
------------
echo (47659.45-47658.35);
// will return 1.0999999999985, which 13 decimals point
// should return "1.10" right ? why "1.0999999999985" ?

Expected result:
----------------
1.10

Actual result:
--------------
1.0999999999985

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-18 13:17 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2012-10-18 13:17 UTC] nikic@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 [2012-10-18 14:17 UTC] mikeyap2005 at gmail dot com
thanks for your quick response.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 00:01:24 2020 UTC