php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63223 undefined symbol: gearman_worker_set_identifier
Submitted: 2012-10-05 14:20 UTC Modified: 2013-02-18 00:36 UTC
Votes:9
Avg. Score:4.7 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:5 (62.5%)
Same OS:4 (50.0%)
From: korchasa at gmail dot com Assigned: hradtke (profile)
Status: No Feedback Package: gearman (PECL)
PHP Version: Irrelevant OS: Ubuntu 12.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: korchasa at gmail dot com
New email:
PHP Version: OS:

 

 [2012-10-05 14:20 UTC] korchasa at gmail dot com
Description:
------------
Hello!

I can't run gearman-extension 1.1.0. Build was successfull, but gearman falls on 
startup. PHP and all modules was installed from Ubuntu repository. On 1.0.3 
everything fine.

Gearman-extension version: 1.1.0 

PHP version: PHP 5.4.6-2~lucid+1 (cli) (built: Aug 30 2012 14:30:01) 

PHP modules:
bcmath
bz2
calendar
Core
ctype
curl
date
dba
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
hash
http
iconv
json
libxml
mbstring
mhash
mysql
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
Phar
posix
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

Pecl install log:
downloading gearman-1.1.0.tgz ...
Starting to download gearman-1.1.0.tgz (30,488 bytes)
.........done: 30,488 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
building in /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0
running: /tmp/pear/temp/gearman/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/20100525
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate 
PHP parsers.
checking for gawk... gawk
checking whether to enable gearman support... yes, shared
found in /usr
checking for gearman_client_set_context in -lgearman... yes
checking for gearman_worker_set_server_option in -lgearman... yes
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-
linux-gnu format... func_convert_file_noop
checking how to convert x86_64-unknown-linux-gnu file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... (cached) gawk
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared 
libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/libtool --
mode=compile cc  -I. -I/tmp/pear/temp/gearman -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/include -
I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/main -
I/tmp/pear/temp/gearman -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2 -Wall   -c 
/tmp/pear/temp/gearman/php_gearman.c -o php_gearman.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/gearman -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/include -
I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/main -
I/tmp/pear/temp/gearman -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -Wall -c 
/tmp/pear/temp/gearman/php_gearman.c  -fPIC -DPIC -o .libs/php_gearman.o
/tmp/pear/temp/gearman/php_gearman.c: In function 'zif_gearman_job_send_data':
/tmp/pear/temp/gearman/php_gearman.c:1495:4: warning: implicit declaration of 
function 'gearman_job_error' [-Wimplicit-function-declaration]
/tmp/pear/temp/gearman/php_gearman.c:1495:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 
'zif_gearman_job_send_warning':
/tmp/pear/temp/gearman/php_gearman.c:1523:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 'zif_gearman_job_send_status':
/tmp/pear/temp/gearman/php_gearman.c:1546:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 
'zif_gearman_job_send_complete':
/tmp/pear/temp/gearman/php_gearman.c:1568:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 
'zif_gearman_job_send_exception':
/tmp/pear/temp/gearman/php_gearman.c:1590:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 'zif_gearman_job_send_fail':
/tmp/pear/temp/gearman/php_gearman.c:1609:4: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/tmp/pear/temp/gearman/php_gearman.c: In function 'zif_gearman_worker_set_id':
/tmp/pear/temp/gearman/php_gearman.c:3318:2: warning: implicit declaration of 
function 'gearman_worker_set_identifier' [-Wimplicit-function-declaration]
/tmp/pear/temp/gearman/php_gearman.c: In function 
'_php_worker_function_callback':
/tmp/pear/temp/gearman/php_gearman.c:3548:6: warning: format '%s' expects 
argument of type 'char *', but argument 4 has type 'int' [-Wformat]
/bin/bash /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/libtool --mode=link 
cc -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/include -
I/tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/main -
I/tmp/pear/temp/gearman -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2 -Wall   -o gearman.la -
export-dynamic -avoid-version -prefer-pic -module -rpath /tmp/pear/temp/pear-
build-rootC5tiGD/gearman-1.1.0/modules  php_gearman.lo -lgearman -lgearman
libtool: link: cc -shared  -fPIC -DPIC  .libs/php_gearman.o   -lgearman  -O2   -
Wl,-soname -Wl,gearman.so -o .libs/gearman.so
libtool: link: ( cd ".libs" && rm -f "gearman.la" && ln -s "../gearman.la" 
"gearman.la" )
/bin/bash /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/libtool --
mode=install cp ./gearman.la /tmp/pear/temp/pear-build-rootC5tiGD/gearman-
1.1.0/modules
libtool: install: cp ./.libs/gearman.so /tmp/pear/temp/pear-build-
rootC5tiGD/gearman-1.1.0/modules/gearman.so
libtool: install: cp ./.libs/gearman.lai /tmp/pear/temp/pear-build-
rootC5tiGD/gearman-1.1.0/modules/gearman.la
libtool: finish: 
PATH="/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbi
n" ldconfig -n /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /tmp/pear/temp/pear-build-rootC5tiGD/gearman-1.1.0/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Test script:
---------------
php -r "echo 'foo';"


Expected result:
----------------
foo

Actual result:
--------------
PHP Warning:  PHP Startup: Unable to load dynamic library 
'/usr/lib/php5/20100525/gearman.so' - /usr/lib/php5/20100525/gearman.so: 
undefined symbol: gearman_worker_set_identifier in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-09 21:45 UTC] mail at aurimas dot eu
Hi, I had the same issue. Apparently, you also need to update your gearmand 
server to the latest version.
 [2012-10-09 21:52 UTC] hradtke@php.net
Are the gearmand version requirements on https://github.com/hradtke/pecl-gearman 
incorrect?
 [2012-10-09 21:52 UTC] hradtke@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: hradtke
 [2012-10-10 12:48 UTC] korchasa at gmail dot com
Thanks! On 1.1.1 everything looks fine.
 [2012-10-10 15:09 UTC] hradtke@php.net
-Status: Feedback +Status: Not a bug
 [2012-10-10 15:09 UTC] hradtke@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2012-10-12 00:11 UTC] korchasa at gmail dot com
IMHO, it's a bug in configure script - missed check for libgearman version.
 [2012-10-12 01:45 UTC] hradtke@php.net
-Status: Not a bug +Status: Assigned
 [2012-10-12 01:46 UTC] hradtke@php.net
I will see if libgearman exposes that information in a way I can reliably check 
for it.
 [2012-10-26 16:12 UTC] nospam at trash-mail dot com
Everybody on the newest Ubuntu (12.10) will basically run into this issue when 
installing Gearman via apt-get and then the gearman php extension via pecl, 
because the version apparently don't play nice together.
 [2012-10-31 10:57 UTC] nospam at trash-mail dot com
There is now also a bug report in launchpad:
http://bugs.launchpad.netgearmand/+bug/1073524
 [2012-11-04 18:10 UTC] hradtke@php.net
-Status: Assigned +Status: Feedback
 [2012-11-04 18:10 UTC] hradtke@php.net
I added some comments to the bug report on Launchpad.

I updated the config.m4 with the updated libgearman requirement: 
https://github.com/hradtke/pecl-
gearman/commit/7e2f08884a15f8a4e144ef18d60e97ea24b0f3b5

As I mentioned in my comment on Launchpad: The symbol 
"gearman_worker_set_identifier" exists in libgearman-0.33. I am not sure why it 
cannot find that symbol.

Is there some way to notify Ubuntu of this problem so we can get the two packages 
in sync?
 [2012-11-07 04:04 UTC] korchasa at gmail dot com
In my case was 12.04, not a quantal(12.10). 12.04 have 0.27 libgearman:

$sudo aptitude show libgearman6
Package: libgearman6                     
State: installed
Automatically installed: yes
Version: 0.27-5ubuntu3
...
 [2013-02-18 00:36 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 21 15:03:37 2021 UTC