php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63221 configure --prefix=/opt fails to search /opt/<subdirs> for packages
Submitted: 2012-10-05 10:06 UTC Modified: 2012-12-26 23:45 UTC
From: mamfelt at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: Irrelevant OS: AIX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mamfelt at gmail dot com
New email:
PHP Version: OS:

 

 [2012-10-05 10:06 UTC] mamfelt at gmail dot com
Description:
------------
./configure --prefix /opt

====
Basically, to resolve this I "patch" configure so that all references to /usr/local are replaced by /opt.

Note: I have tried
./buildconf --force

but get the following message:
root@x104:[/data/prj/php/php-RC1-5.3.18]./buildconf --force
Forcing buildconf
buildconf: checking installation...
buildconf: You need autoconf 2.59 or lower to build this version of PHP.
           You are currently trying to use 2.68
           Most distros have separate autoconf 2.13 or 2.59 packages.
           On Debian/Ubuntu both autoconf2.13 and autoconf2.59 packages exist.
           Install autoconf2.13 and set the PHP_AUTOCONF env var to 
           autoconf2.13 and try again.
make: *** [buildmk.stamp] Error 1

======
I went to the autoconf downloads and see that autoconf-2.59 is rather ancient, and wonder if this problem is already resolved using newer tools?


[   ] autoconf-2.12.tar.gz                      26-Nov-1996 03:00  401K  
[   ] autoconf-2.13.tar.gz                      15-Jan-1999 16:03  433K  
[   ] autoconf-2.50-2.52.xdelta                 18-Jul-2001 09:59   58K  
...
[   ] autoconf-2.59.tar.bz2                     16-Dec-2003 15:53  903K  
[   ] autoconf-2.59.tar.bz2.sig                 16-Dec-2003 15:52   65   
[   ] autoconf-2.59.tar.gz                      16-Dec-2003 15:52  1.2M  
[   ] autoconf-2.59.tar.gz.sig                  16-Dec-2003 15:52   65   
[   ] autoconf-2.60.tar.bz2                     26-Jun-2006 13:02  1.0M  
...
[   ] autoconf-2.68.tar.xz                      22-Sep-2010 18:54  1.1M  
[   ] autoconf-2.68.tar.xz.sig                  22-Sep-2010 18:54  556   
[   ] autoconf-2.69.tar.gz                      24-Apr-2012 23:17  1.8M  
[   ] autoconf-2.69.tar.gz.sig                  24-Apr-2012 23:17  556   
[   ] autoconf-2.69.tar.xz                      24-Apr-2012 23:17  1.2M  
[   ] autoconf-2.69.tar.xz.sig                  24-Apr-2012 23:17  556   

Test script:
---------------
./configure --prefix=/opt

...
checking for xml2-config path... 
configure: error: xml2-config not found. Please check your libxml2 installation.

root@x104:[/data/prj/php/php-RC1-5.3.18]

Expected result:
----------------
...
...
+--------------------------------------------------------------------+
| License:                                                           |
| This software is subject to the PHP License, available in this     |
| distribution in the file LICENSE.  By continuing this installation |
| process, you are bound by the terms of this license agreement.     |
| If you do not agree with the terms of this license, you must abort |
| the installation process at this point.                            |
+--------------------------------------------------------------------+

Thank you for using PHP.

Actual result:
--------------
checking for xml2-config path... 
configure: error: xml2-config not found. Please check your libxml2 installation.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-22 00:52 UTC] sixd@php.net
The --prefix option is the directory that PHP will be installed. It isn't used 
as a search path.  Run "./configure --help" to check the option to use.  See  --
with-libxml-dir

PHP 5.4 uses the 2.59+ versions of the tools

To use a specific version of the build tools, install that version and then run, 
for example:
  export PHP_AUTOCONF=autoconf-2.13
  export PHP_AUTOHEADER=autoheader-2.13
  ./buildconf

If you use buildconf in older versions of PHP, you need to manually clear the 
caches first with:
  rm -rf config.cache autom4te.cache
 [2012-10-22 00:52 UTC] sixd@php.net
-Status: Open +Status: Not a bug
 [2012-12-26 23:45 UTC] mamfelt at gmail dot com
thanks for the explanation. I am used to it working for both. I must have made 
similiar errors in the past with the --with-something-dir= option, and it does 
work for some. c'est la vie.

p.s. I have not used buildconf - trying to work from distro asis.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 04:05:45 2022 UTC