php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63215 Add support for Firebird commit retaining transactions.
Submitted: 2012-10-04 00:01 UTC Modified: 2018-07-06 19:06 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: james at kenjim dot com Assigned:
Status: Duplicate Package: PDO Firebird
PHP Version: 5.4Git-2012-10-03 (Git) OS: All
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: james at kenjim dot com
New email:
PHP Version: OS:

 

 [2012-10-04 00:01 UTC] james at kenjim dot com
Description:
------------
Add the ability to do commit retaining transactions using the Firebird PDO driver.  Commit retaining is faster when committing because it reuses server transaction resources.  The downside is you are still in the old transaction context so you won't see any new concurrent commits.  Commit retaining is ideally used when you have lots of small transactions that do not rely on other data that may be changed by another thread/user.

I have written a patch to add the ability to do commit retaining transactions using 
$dbh->setAttribute(PDO::FB_ATTR_COMMIT_RETAINING, true);
Any following commits or rollbacks will use their retaining equivalent after this attribute is set.  You can return to using normal commit and rollbacks by setting the attribute to false.
$dbh->setAttribute(PDO::FB_ATTR_COMMIT_RETAINING, false);


Patches

CommitRetaining (last revision 2012-10-04 00:02 UTC by james at kenjim dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-23 13:21 UTC] mariuz@php.net
-Assigned To: +Assigned To: mariuz
 [2012-12-05 07:22 UTC] james at kenjim dot com
I have uploaded a new improved patch with Bug #63690 that includes the functionality here.  I suggest using that patch instead of the one I uploaded here as that is a more complete solution and fixes some unexpected behavior if someone uses commit retaining.
 [2016-08-29 14:29 UTC] cmb@php.net
-Package: PDO related +Package: PDO Firebird
 [2017-10-24 06:45 UTC] kalle@php.net
-Status: Assigned +Status: Open -Assigned To: mariuz +Assigned To:
 [2018-07-06 19:06 UTC] ab@php.net
-Status: Open +Status: Duplicate
 [2018-07-06 19:06 UTC] ab@php.net
According to the @james comment, this ticket is now superseded.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 23:01:24 2020 UTC