php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #63135 Additional explanation for [mixed $entries] parameter
Submitted: 2012-09-21 20:19 UTC Modified: 2016-06-14 14:40 UTC
From: twilightfog at yahoo dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: twilightfog at yahoo dot com
New email:
PHP Version: OS:

 

 [2012-09-21 20:19 UTC] twilightfog at yahoo dot com
Description:
------------
---
From manual page: http://www.php.net/ziparchive.extractto
---
The manual states that the second parameter to the function: [mixed $entries] can be an array. However, it does not mention that when it is an empty array, nothing will be extracted. 

This is a important distinction as the array may be generated dynamically, and without mentioning this in the documentation the users may expect that an empty array will extract all the entries in the zip files.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-14 14:40 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-06-14 14:40 UTC] cmb@php.net
I think the manual is pretty clear about that:

| entries
| The entries to extract. It accepts either a single entry name or
| an array of names.

So, if an empty array is passed, no entry is extracted.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 01:01:23 2020 UTC