php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #63127 Manual down
Submitted: 2012-09-21 08:00 UTC Modified: 2012-09-22 17:20 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: cornelis96 at gmail dot com Assigned: tyrael (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cornelis96 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-09-21 08:00 UTC] cornelis96 at gmail dot com
Description:
------------
The whole manual folder is empty whole documentation not available

http://li.php.net/manual/




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-21 08:08 UTC] aharvey@php.net
Looks like we have a doc build issue of some description:

adamh@swiftdesk7:/tmp$ rsync -avz --progress --partial rsync.php.net::phpweb/manual/en .
receiving file list ... 
1 file to consider

sent 82 bytes  received 73 bytes  62.00 bytes/sec
total size is 0  speedup is 0.00

Not all translations are currently affected (nor are all mirrors, since presumably some have yet to update): French, Japanese, Polish, Romanian, Russian, Persian, Spanish and Turkish still rsync as expected. This may just be because they haven't been built yet.
 [2012-09-21 09:09 UTC] tyrael@php.net
I've commited a fix to the (possible) underlying permission issue at 
http://git.php.net/?
p=systems.git;a=commitdiff;h=14d48fa21cc54f782e545dcd63f3d087fa473866
we would still need to rebuild the documentations on rsync.php.net and then the 
mirrors should catch up with it.
 [2012-09-21 09:09 UTC] tyrael@php.net
-Package: Website problem +Package: Systems problem
 [2012-09-21 11:36 UTC] White-Gandalf at web dot de
Only 2 documentation languages available worldwide: french and persian.

This is NOT irrelevant.
It's possible to direct students to the english pages, but no way to persian!
what i need is german!

There are only a few mirrors left, keeping the old state.
I suggest stopping mirror updates at once (!) until the bug is gone!
 [2012-09-21 11:40 UTC] cornelis96 at gmail dot com
I found a `still` working manual take a scraper and save yourself

http://fi2.php.net/manual/en/function.date.php
 [2012-09-21 11:46 UTC] tyrael@php.net
Gandalf:
the PHP version is indeed irrelevant, as this isn't a bug in one of the php 
versions, but an infrastructure problem.
unfortunately I can't stop the mirrors from pulling the bad version.
 [2012-09-21 11:51 UTC] cornelis96 at gmail dot com
When do you think this issue is fixed?
 [2012-09-21 12:14 UTC] tyrael@php.net
unfortunately we couldn't reach the staff handling the documentation builds, so we 
had to improvise a little bit, but if we didn't screw up anything, the docs are 
building now.
building all of the languages can take a few hours (~2-4 AFAIR), and after that 
the mirrors are still have to pull the changes (depending on the cron settings 
there, it could take a few hours also).
I would propose using http://docs.php.net/docs.php as it is built separately so it 
shouldn't be affected by the mirroring issue.
 [2012-09-21 17:12 UTC] tyrael@php.net
the docs finished building, and is available on rsync.php.net, the mirrors are 
catching up.
everything should be back to normal soon.
 [2012-09-22 17:20 UTC] tyrael@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: tyrael
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC