php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62973 $_POST or $_GET don't work with 'id' attribute in XHTML form
Submitted: 2012-08-30 11:02 UTC Modified: 2012-08-30 12:08 UTC
From: me at walkinraven dot name Assigned:
Status: Not a bug Package: Variables related
PHP Version: 5.3.16 OS: Ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: me at walkinraven dot name
New email:
PHP Version: OS:

 

 [2012-08-30 11:02 UTC] me at walkinraven dot name
Description:
------------
XHTML 1.1 specification says:

drop 'name', but 'id' only.

But if really follow so, the PHP can't deal with such 'standard form'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-30 12:08 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-08-30 12:08 UTC] aharvey@php.net
This really isn't up to PHP: it's entirely down to the user-agent to decide what 
should get sent. It's all a key => value map as far as PHP is concerned.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 06:01:38 2024 UTC