php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62968 Unable to Run PHP with IIS 7.X
Submitted: 2012-08-29 13:31 UTC Modified: 2012-10-08 17:31 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: bankim dot rana at strixsystems dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.4.6 OS: windows 2008 64 bit R2 sp1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bankim dot rana at strixsystems dot com
New email:
PHP Version: OS:

 

 [2012-08-29 13:31 UTC] bankim dot rana at strixsystems dot com
Description:
------------
We are getting "HTTP Error 500.0 - Internal Server Error" while run any php file on IIS 7 and above on windows 2008 R2 sp1 OS with 64 bit.
Details about error
Module IsapiModule -> Requested URL http://localhost:80/phpinfo.php 

Notification ExecuteRequestHandler - Physical Path C:\inetpub\wwwroot\phpinfo.php 

Handler PHP-ISPAI - Logon Method Anonymous
Error Code 0x8007007e - Logon User Anonymous 


Test script:
---------------
<?php echo phpinfo(); ?>

Expected result:
----------------
it shuld display php.ini configuration


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-08 17:31 UTC] mattficken@php.net
-Status: Open +Status: Not a bug
 [2012-10-08 17:31 UTC] mattficken@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

ISAPI is not supported by PHP. You should not use it.

You should use FastCGI instead. If instructions, tutorials, etc... weren't clear on this, then let us know because that will need to be fixed.

For instructions on how to setup PHP with IIS, see this link: http://www.iis.net/learn/application-frameworks/install-and-configure-php-applications-on-iis/using-fastcgi-to-host-php-applications-on-iis. 

You can also try WebPI and PHP Manager, both available on iis.net.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 20:03:45 2023 UTC