php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #62963 Invalid description of return values in function strcasecmp (allways 0)
Submitted: 2012-08-29 09:11 UTC Modified: 2012-08-29 09:15 UTC
From: srobowak at azet dot sk Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: srobowak at azet dot sk
New email:
PHP Version: OS:

 

 [2012-08-29 09:11 UTC] srobowak at azet dot sk
Description:
------------
---
From manual page: http://www.php.net/function.strcasecmp#refsect1-
function.strcasecmp-returnvalues
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-29 09:15 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-08-29 09:15 UTC] aharvey@php.net
No, the documentation is correct: strcasecmp() will return an integer, and that integer will only be 0 if the input strings are case-insensitively equal.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 10:01:24 2020 UTC