PHP :: Bug #62934 :: mb_convert_kana() does not convert iteration marks
php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62934 mb_convert_kana() does not convert iteration marks
Submitted: 2012-08-26 11:03 UTC Modified: 2012-09-21 02:19 UTC
Votes:2
Avg. Score:2.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: scin dot ichi at gmail dot com Assigned: moriyoshi (profile)
Status: Closed Package: mbstring related
PHP Version: 5.3.16 OS: any platform
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
6 + 49 = ?
Subscribe to this entry?

 
 [2012-08-26 11:03 UTC] scin dot ichi at gmail dot com
Description:
------------
mb_convert_kana() does not convert japanese iteration marks (odori-ji).

* Hiragana to Katakana ($option = 'C')
ゝ and ゞ must be converted ヽ and ヾ

* Katakana to Hiragana ($option = 'c')
ヽ and ヾ must be converted ゝ and ゞ


Test script:
---------------
<?php
echo mb_convert_kana('あゝすゞめアヽスヾメ', 'C', 'UTF-8') . PHP_EOL;
echo mb_convert_kana('あゝすゞめアヽスヾメ', 'c', 'UTF-8') . PHP_EOL;


Expected result:
----------------
アヽスヾメアヽスヾメ
あゝすゞめあゝすゞめ

Actual result:
--------------
アゝスゞメアヽスヾメ
あゝすゞめあヽすヾめ

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-04 17:27 UTC] ajf at ajf dot me
Had a look. Turns out this is an issue with libmbfl, which mbstring uses. Not 
sure if it can be updated or not, someone else should look into it. But it's not 
an issue with mbstring itself, mb_convert_kana passes through to 
mbl_ja_jp_hantozen.
 [2012-09-21 02:19 UTC] moriyoshi@php.net
-Assigned To: +Assigned To: moriyoshi
 [2017-07-28 11:04 UTC] nikic@php.net
Automatic comment on behalf of nikita.ppv@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=e3d25e78eb73c7b7bce0cd175578f7ce32741c5f
Log: Fixed bug #62934
 [2017-07-28 11:04 UTC] nikic@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Aug 14 15:01:26 2018 UTC