php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #62891 Error codes
Submitted: 2012-08-22 12:09 UTC Modified: 2012-08-23 01:15 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: dagguh at gmail dot com Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dagguh at gmail dot com
New email:
PHP Version: OS:

 

 [2012-08-22 12:09 UTC] dagguh at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.fsockopen
---
Error codes are not documented. Error messages might be insufficient or simply 
wrong.
We are getting error code 146 with error message "Connection refused".
Our network team state that there is no possibility of connection being refused, 
because the machines are in the same subnetwork.
We are using fsockopen with a 1 second timeout. I wonder if this error is simply 
the timeout, but fsockopen reports wrong error.

If error codes were documented, we would be sure what exactly "Connection 
refused" means and maybe we would see a seperate error for a timeout.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-23 01:15 UTC] aharvey@php.net
-Status: Open +Status: Wont fix -Package: Sockets related +Package: Documentation problem
 [2012-08-23 01:15 UTC] aharvey@php.net
Ultimately, the error codes in I/O-related warning and error messages are entirely OS-dependent. I don't think there's a lot we can do here that would make things better rather than worse: trying to cover the common cases may only lead to confusion for people using less common operating systems.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 14:01:33 2024 UTC