php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62853 Support for parsing vlv control response
Submitted: 2012-08-18 13:57 UTC Modified: 2017-09-27 15:23 UTC
Votes:6
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:5 (100.0%)
From: vanmeeuwen at kolabsys dot com Assigned: heiglandreas (profile)
Status: Closed Package: LDAP related
PHP Version: 5.4.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vanmeeuwen at kolabsys dot com
New email:
PHP Version: OS:

 

 [2012-08-18 13:57 UTC] vanmeeuwen at kolabsys dot com
Description:
------------
A Virtual List View control response includes the total number of entries in the virtual list view used.

An additional function is needed to get to that response, and be able to efficiently list a properly paginated ($1 to $2 entries of $3 total) LDAP directory information tree.

Test script:
---------------
Example use of this new function can be found at, for example;

  https://github.com/roundcube/roundcubemail/blob/master/program/include/rcube_ldap.php#L1409

  http://git.kolab.org/pear/Net_LDAP3/tree/lib/Net/LDAP3.php#n728


Patches

0001-Add-function-ldap_parse_virtual_list_control.patch (last revision 2012-08-18 13:57 UTC by vanmeeuwen at kolabsys dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-15 16:21 UTC] hjf288 at gmail dot com
This is pretty essential, can we get it reviewed please?
 [2017-01-09 17:01 UTC] heiglandreas@php.net
I'm sorry that this patch never made it into the language. But by now it targets an unsupported version of PHP.

Would you update the patch to match a current version of PHP or create a PR against https://github.com/php/php-src?
 [2017-01-09 17:02 UTC] heiglandreas@php.net
-Status: Open +Status: Feedback
 [2017-01-10 08:00 UTC] heiglandreas@php.net
-Assigned To: +Assigned To: heiglandreas
 [2017-01-22 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2017-09-27 15:23 UTC] mcmic@php.net
-Status: No Feedback +Status: Closed
 [2017-09-27 15:23 UTC] mcmic@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Support for VLV control has been added and will be available in PHP 7.3
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 15:05:53 2022 UTC