php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62843 configure script does not check for libpcre
Submitted: 2012-08-17 06:55 UTC Modified: 2014-08-02 17:47 UTC
From: martijn dot otto at copernica dot com Assigned:
Status: Duplicate Package: oauth (PECL)
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: martijn dot otto at copernica dot com
New email:
PHP Version: OS:

 

 [2012-08-17 06:55 UTC] martijn dot otto at copernica dot com
Description:
------------
OAuth depends on libpcre. The configure script does not check for this, which will 
result in a botched build if libpcre is not installed.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-08-02 03:18 UTC] cweiske@php.net
-Status: Open +Status: Duplicate
 [2014-08-02 03:18 UTC] cweiske@php.net
Duplicate of bug #67658.
 [2014-08-02 17:47 UTC] jawed@php.net
Similar to Remi's point about pcre.h (which I agree needs a header check)...libpcre should exist as PHP's dependency regardless of how it's linked?

I can foresee configurations where the header isn't around for but AFAIK libpcre is a core dependency?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 21:03:39 2021 UTC