php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #62774 split is deprecated since 5.3, okay. what to use instead? suggestion missing.
Submitted: 2012-08-08 07:22 UTC Modified: 2012-11-15 09:58 UTC
From: aseleznyov at parallels dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aseleznyov at parallels dot com
New email:
PHP Version: OS:

 

 [2012-08-08 07:22 UTC] aseleznyov at parallels dot com
Description:
------------
---
From manual page: http://www.php.net/function.split#refsect1-function.split-description
---


Test script:
---------------
suggestion is missing, what to use instead of deprecated split() function.

Expected result:
----------------
suggestion is added next to deprecation warning.

Actual result:
--------------
suggestion is missing.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-08 08:07 UTC] salathe@php.net
I encourage you to keep reading the page. Further down, we have several notes 
suggesting to use the PCRE extension and in particular preg_split().  The page 
also mentions "the list of differences" (between POSIX and PCRE regex), which 
contains a table of suggested replacements for the POSIX regex functions.

Is that enough to find the information that you're wanting, or are you really 
just trying to push for "hey, use preg_split()!" within the Big Red Box?
 [2012-08-08 08:28 UTC] aseleznyov at parallels dot com
Yes, suggestion should be within the Big Red Box.
Without it here, reader is forced to read through the whole description of already deprecated function, and this seems nonsense.

Probably, just "Use preg_split()[link] or explode()[link] instead." at the end warning message.
 [2012-11-15 09:58 UTC] krakjoe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

"See Also" is the established way of conveying this information.
 [2012-11-15 09:58 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 13:01:26 2020 UTC