php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62741 Authentication LDAP
Submitted: 2012-08-03 13:53 UTC Modified: 2017-01-09 20:37 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: superfelo at yahoo dot com Assigned:
Status: Wont fix Package: LDAP related
PHP Version: 5.3.15 OS: Windows Server 2003 SP2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: superfelo at yahoo dot com
New email:
PHP Version: OS:

 

 [2012-08-03 13:53 UTC] superfelo at yahoo dot com
Description:
------------
Error when trying to authenticate with Active Directory (Windows Server 2003 SP2).
Is something missing to install on windows?

php.ini
extension=php_ldap.dll
extension=php_openssl.dll

Apache: 2.2.22

Test script:
---------------
$t_br = @ldap_sasl_bind ( $t_ds, NULL, $p_password , "GSSAPI", NULL, $p_binddn, NULL);

or

$t_br = @ldap_sasl_bind ( $t_ds, NULL, $p_password , "NTLM", NULL, $p_binddn, NULL);

or

$t_br = @ldap_sasl_bind ( $t_ds, NULL, $p_password , "DIGEST-MD5", NULL, $p_binddn, NULL);


Expected result:
----------------
Authentication failed or ok.

Actual result:
--------------
Unknown authentication method

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-09 16:58 UTC] heiglandreas@php.net
-Status: Open +Status: Wont fix
 [2017-01-09 16:58 UTC] heiglandreas@php.net
As this issue is by now over 4 years old and targets an unsupported version of PHP (as well as ActiveDirectory) I'm closing this.

Should the issue not be resolved by now feel free to (re)open the matter.
 [2017-01-09 20:37 UTC] superfelo at yahoo dot com
It happens the same in the last version of php, only that I lost the hope that they fix it.
Apparently, the problem is that it lacks support for Cyrus SASL.
By the way if it is the problem is with ActiveDirectory not worth fixing?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 15:03:33 2022 UTC