php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6272 xor causes httpd to exit on sig 8 (floating point exception)
Submitted: 2000-08-21 07:48 UTC Modified: 2000-08-21 07:51 UTC
From: pgl at instinct dot org Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 4.0.1pl2 OS: FreeBSD 3.4-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pgl at instinct dot org
New email:
PHP Version: OS:

 

 [2000-08-21 07:48 UTC] pgl at instinct dot org
using the ^ operator on my system causes httpd to die with sig 8. here's the line from the error_log:

[Mon Aug 21 12:36:10 2000] [notice] child pid 42640 exit signal Floating point exception (8)

here's the code:

http://miki.instinct.org/~pgl/xor.phps

found out because someone was complaining in alt.php that xor didn't return the correct value.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-21 07:51 UTC] stas@php.net
This should be already fixed in CVS. Please reopen if it still happens in latest CVS.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 09:01:23 2020 UTC