php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62669 Memory leak in is_readable
Submitted: 2012-07-26 18:21 UTC Modified: 2012-07-27 03:26 UTC
From: mr_pain at operamail dot com Assigned:
Status: Duplicate Package: Filesystem function related
PHP Version: 5.4.5 OS: XP SP3, Vista, W7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mr_pain at operamail dot com
New email:
PHP Version: OS:

 

 [2012-07-26 18:21 UTC] mr_pain at operamail dot com
Description:
------------
When function is_readable is run it leaves an open handle in the httpd process.

Additional information:
-----------------------
Memory leak confirmed for the following configurations:
PHP vc9 5.3.15, thread safe version + Apache Httpd 2.4.2 + Win XP SP3 
PHP vc9 5.4.5,  thread safe version + Apache Httpd 2.4.2 + Win XP SP3 

PHP vc9 5.4.5 tested on WAMP stacks:
------------------------------------
XAMPP USB Lite 1.8.0        (Windows XP SP3)
Uniform Server 8.5.8-Coral  (Windows XP SP3)

For details see:
http://forum.uniformserver.com/index.php?showtopic=2627&hl=
Windows 7 SP1 and Windows Server 2008 R2 (both is 64-bit OS)

The above memory leak makes running PHP on Windows production server impractical.


Test script:
---------------
for($i=0; $i<100;$i++) {
  is_readable("c:\\temp");
}

NOTE: the folder/file must exist for the leak to happen.

Expected result:
----------------
No leaked handles

Actual result:
--------------
100 leaked handles

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-27 03:26 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2012-07-27 03:26 UTC] aharvey@php.net
Duplicate of bug #62444.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC