php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62641 curl_multi times out
Submitted: 2012-07-23 15:08 UTC Modified: 2012-09-22 14:34 UTC
From: jimi_barka at yahoo dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.4.5 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jimi_barka at yahoo dot com
New email:
PHP Version: OS:

 

 [2012-07-23 15:08 UTC] jimi_barka at yahoo dot com
Description:
------------
Running the sample script provided here: http://php.net/manual/en/function.curl-multi-init.php results in a timeout. This bug is not present in version 5.3.8, but does appear in 5.4.0 and in later versions, including version 5.4.5.

PHP info (excerpt):
System 	Windows NT 6.1 build 7601 (Windows 7 Business Edition Service Pack 1) i586
Build Date 	Jul 18 2012 22:21:56
Compiler 	MSVC9 (Visual C++ 2008)
Architecture 	x86
Configure Command 	cscript /nologo configure.js "--enable-snapshot-build" "--disable-isapi" "--enable-debug-pack" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze" "--with-pgo" 

Apache Version 	Apache/2.2.22 (Win32) PHP/5.4.5 


Binaries from http://windows.php.net/downloads/releases/php-5.4.5-Win32-VC9-x86.zip

Test script:
---------------
http://php.net/manual/en/function.curl-multi-init.php
Example #1 curl_multi_init() example

Expected result:
----------------
Display contents of http://lxr.php.net/ and http://www.php.net/

Actual result:
--------------
Script times out with a message:
Fatal error: Maximum execution time of 30 seconds exceeded in E:\www\curl.php on line 26

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-22 14:34 UTC] pierrick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

This bug is a duplicate of Bug #61141
 [2012-09-22 14:34 UTC] pierrick@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 10:01:26 2019 UTC