php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62631 Malformed error messages (contain invalid characters)
Submitted: 2012-07-22 03:09 UTC Modified: 2012-07-22 03:39 UTC
From: bugs dot php dot net at majkl578 dot cz Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: 5.4.5 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
49 - 43 = ?
Subscribe to this entry?

 
 [2012-07-22 03:09 UTC] bugs dot php dot net at majkl578 dot cz
Description:
------------
After running a test script below, CLI SAPI correctly outputs an expected error message, but FPM SAPI (at least) doesn't. The error message contains some invalid characters after the class name. Also the name of class & method are completely missing in the message.
I also attached an url-encoded version (to preserve invalid characters) of the message caught by error_get_last() in a shutdown handler.

Test script:
---------------
<?php

$foo = new stdClass();
echo $foo->bar();

Expected result:
----------------
Fatal error: Call to undefined method stdClass::bar() in /www/temp.php on line 10

Actual result:
--------------
Fatal error: in /www/temp.php on line 10

----------------

URL-encoded version of the error message:
Fatal+Error+Call+to+undefined+method+stdClass%E0%08K%B4c%F0%CB%DB%0C%3A%3Abar()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-22 03:13 UTC] rasmus@php.net
-Status: Open +Status: Feedback
 [2012-07-22 03:13 UTC] rasmus@php.net
Are you using APC? If so, which version?
 [2012-07-22 03:29 UTC] bugs dot php dot net at majkl578 dot cz
-Status: Feedback +Status: Open
 [2012-07-22 03:29 UTC] bugs dot php dot net at majkl578 dot cz
Yes, 3.1.11-dev. After updating to 3.1.11 release, the problem seems to be gone.
 [2012-07-22 03:39 UTC] rasmus@php.net
Right, thought so.
 [2012-07-22 03:39 UTC] rasmus@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 21 08:01:27 2019 UTC