php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62619 com_create_guid not available anymore
Submitted: 2012-07-20 11:41 UTC Modified: 2012-07-20 13:02 UTC
From: mb at smartftp dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.4.5 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mb at smartftp dot com
New email:
PHP Version: OS:

 

 [2012-07-20 11:41 UTC] mb at smartftp dot com
Description:
------------
The com_create_guid function does not seem to be available anymore in PHP 5.4.5.

Test script:
---------------
com_create_guid();


Expected result:
----------------
no error

Actual result:
--------------
PHP Fatal error:  Call to undefined function com_create_guid()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-20 12:30 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2012-07-20 12:30 UTC] ab@php.net
The com_dotnet extension isn't compiled in statically anymore. It's still 
available as a shared extension and must be activated in php.ini. See UPGRADING 
windows section.
 [2012-07-20 13:02 UTC] mb at smartftp dot com
It is certainly not a good idea to make such a change in a maintenance release 
(5.4.5) as the functions were still available in 5.4.4.
There was also nothing mentioned in the official changelog/NEWS.
 [2012-07-20 17:21 UTC] ab@php.net
But in official UPGRADING :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 23:05:54 2022 UTC