php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62601 Only one persistent connection doing work at a time
Submitted: 2012-07-18 17:00 UTC Modified: 2012-10-22 07:17 UTC
From: rahulpriyadarshi@php.net Assigned: rahulpriyadarshi (profile)
Status: Not a bug Package: ibm_db2 (PECL)
PHP Version: Irrelevant OS: AIX 7.1 TL 1 SP 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rahulpriyadarshi@php.net
New email:
PHP Version: OS:

 

 [2012-07-18 17:00 UTC] rahulpriyadarshi@php.net
Description:
------------
In a multiple web server environment with identical php code/setup on each web server, there are multiple established connections between web server processes (not threads) and the db2 server.  However, on each of the web servers, only one of those connections is actually doing work.

Changing the connection type from pconnect to connect allows all web server process established connections actually work in parallel.

Environment is:

AIX power 7 LPARS with OS AIX 7.1 Tech level 1 service pack 2
web servers:
apache 2.2.21 - 32 bit compiled
php 5.3.10 - 32 bit compiled
ibm_db2 php extention 1.9.2 - 32 bit compiled
ibm db2 9.7.0.x run time client (some have ga base, some have fix pack 5, some have fix pack 5 with special fix)
db2 servers:
ibm db2 enterprise server edition 9.7.0.5 (some with special fix)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-01 08:38 UTC] rahulpriyadarshi@php.net
-Assigned To: +Assigned To: rahulpriyadarshi
 [2012-10-22 07:17 UTC] rahulpriyadarshi@php.net
The bug originator has told that he doesn't facing this problem anymore.
 [2012-10-22 07:17 UTC] rahulpriyadarshi@php.net
-: rodaj at us dot ibm dot com +: rahulpriyadarshi@php.net -Status: Assigned +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jan 22 17:01:23 2021 UTC