php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62575 can not return value by function 'eval'
Submitted: 2012-07-16 05:32 UTC Modified: 2017-04-01 21:27 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: goodook at 163 dot com Assigned:
Status: Wont fix Package: PHPScript (PECL)
PHP Version: 5.3.14 OS: windowsXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: goodook at 163 dot com
New email:
PHP Version: OS:

 

 [2012-07-16 05:32 UTC] goodook at 163 dot com
Description:
------------
can not return value by use the script Host function 'eval'

[code]:  Debug.Print ScriptControl1.Eval(" 1 + 9;")
print out must be 10, but nothing output.

Test script:
---------------
code:  Debug.Print ScriptControl1.Eval(" 1 + 9;")
print out must be 10, but nothing output.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-16 12:33 UTC] ab@php.net
Could you please give more details on that, may be a worky example to reproduce?
 [2012-07-17 09:13 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2012-07-20 05:14 UTC] goodook at 163 dot com
-Status: Feedback +Status: Open
 [2012-07-20 05:14 UTC] goodook at 163 dot com
VB CODE: 
  Dim f
  ScriptControl1.Language = "PDAscript"
  f = ScriptControl1.Eval("1+9")

here the variable 'f' must be 10
but, 'f' not get the value which return from 'ScriptControl1.Eval'
 [2012-07-20 17:21 UTC] goodook at 163 dot com
ScriptControl1.Language = "VBscript"
f = ScriptControl1.Eval("1+9")
HERE f will be '10'

ScriptControl1.Language = "PHPscript"
f = ScriptControl1.Eval("1+9")
HERE f is null.
 [2017-04-01 21:27 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:27 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 23:01:23 2020 UTC