php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Sec Bug #62554 -c
Submitted: 2012-07-13 14:43 UTC Modified: 2012-07-13 16:24 UTC
From: mbiama at angosso dot net Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.3.14 OS: GNU/linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mbiama at angosso dot net
New email:
PHP Version: OS:

 

 [2012-07-13 14:43 UTC] mbiama at angosso dot net
Description:
------------
Argument passed to save_handler. In the case of files, this is the path where data files are stored. Note: Windows users have to change this variable in order to use PHP's session functions. As of PHP 4.0.1, you can define the path as: session.save_path = "N;/path" where N is an integer. Instead of storing all the session files in /path, what this will do is use subdirectories N-levels deep, and store the session data in those directories. This is useful if you or your OS have problems with lots of files in one directory, and is a more efficient layout for servers that handle lots of sessions. NOTE 1: PHP will not create this directory structure automatically. You can use the script in the ext/session dir for that purpose. NOTE 2: See the section on garbage collection below if you choose to use subdirectories for session storage

Test script:
---------------
/tmp
'./configure' '--prefix=/ect/www/php5' '--with-libdir=lib64' '--sysconfdir=/etc' '--disable-rpath' '--enable-cli' '--disable-cgi' '--with-config-file-path=/var/server/lib/$Dot' '--disable-all' '--enable-libxml' '--with-libxml-dir=/dot' '--with-openssl=/server' '--with-kerberos=/exe' '--with-pcre-regex=/exe' 

Expected result:
----------------
PHP CLI/CGI $Host version run Apache ver. 	2.2.19 (Unix)
PHP version 	5.2.17
main session.save_path ./php.ini
include_path 	SERVER: "\path1;\path2" -c:/php/includes"

Actual result:
--------------
SERVER run in "localhot" only
--enable-debug and disable "http://" Back local

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-13 16:24 UTC] stas@php.net
-Status: Open +Status: Not a bug
 [2012-07-13 16:24 UTC] stas@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 13:01:27 2024 UTC